登录    关于
马育民老师的博客

马育民的博客

QQ:65242847

idea maven 工程报错 java: -source 1.5 中不支持 diamond 运算符

<build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.3.2</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                    <encoding>utf-8</encoding>
                </configuration>
            </plugin>
        </plugins>
    </build>

原文出处:http://malaoshi.top/show_1IX2F8robO0j.html